Visitor Management Module Inaccessible

Incident Report for Equiem

Postmortem

Incident Postmortem: Visitor Management System Outage
Date: 13 May 2025
Duration: 11:33–12:03 (UTC+1)
Status: Resolved

Summary

On 13 May at 11:33 UTC+1, we became aware of an issue affecting the Visitor Management system. During the 30-minute window, users were unable to access key visitor features. The issue was identified and resolved by 12:03, with full service restored across all affected environments.

Impact

During the incident window, users of the Visitor Management system experienced the following issues:

  • Inability to create new visitor entries
  • Reception staff could not view expected guests
  • Reception staff could not see who was currently in the building
  • Check-in functionality for pre-booked visitors was unavailable
  • Walk-in visitor registration was not possible

The impact was global across all customers using the Visitor Management feature.

Root Cause

The incident was triggered by the deployment of a new feature related to visitor access control. An unexpected behaviour occurred in the authentication layer during the deployment process. While the change had undergone standard review and validation procedures, the specific production context introduced an unforeseen issue that affected key service functions.

Resolution

Our engineering team quickly identified the issue and rolled back the affected component. Normal functionality was restored by 12:03 UTC+1.

Preventative Measures

To reduce the risk of recurrence, we are implementing the following improvements:

  • Enhanced validation of authentication flows in production-like environments
  • Introduction of release-specific smoke tests immediately following deployment
  • Clearer scoping and scheduling of work in periods leading up to major internal or external milestones

We appreciate your patience during this time and remain committed to maintaining a stable and reliable platform.

Posted May 14, 2025 - 10:35 UTC

Resolved

The issue affecting the Visitor Management module has now been fully resolved. Access has been restored, and the module is functioning as expected.

We will publish a full postmortem within the next 48 hours.

Thank you for your patience and understanding.
Posted May 12, 2025 - 11:14 UTC

Monitoring

Incident Update: Visitor Management Module Recovery

The Visitor Management module has begun to recover, and customers are starting to regain access.

If you continue to see an error message, please reload your browser or app.

We will continue to monitor the situation and provide further updates as needed.
Posted May 12, 2025 - 11:01 UTC

Investigating

We are currently experiencing an issue with the Visitor Management module, which is temporarily inaccessible.

Current Status:
Our team is actively working to restore functionality. We will provide an update within the next 30 minutes.

Thank you for your patience.
Posted May 12, 2025 - 10:46 UTC
This incident affected: Mobile (Android, iOS), Web, API, and Supporting Applications (Equiem One).