External Bookings - Calendar Sync Issues

Incident Report for Equiem

Postmortem

Incident: External Bookings – Calendar Sync Issues
Date: 21 August 2025
Status: Resolved (all times below in UTC)

Summary (TL;DR)

Between the morning and late evening of 21 August 2025, some customers experienced failures when syncing third-party calendars with the Bookings module. Bookings created and managed directly inside Equiem One were not affected. The issue was traced to a new security check introduced by Microsoft that rejected requests lacking a browser-style user-agent header. We updated our calendar fetch to include a compliant user-agent and deployed the fix the same day. Service returned to normal, and we closed monitoring later that evening.

Impact

  • Affected feature: Third-party calendar sync for External Bookings (ICS feed consumption). Core booking functionality in Equiem One remained fully available.
  • Scope: A limited set of customers across EU, US, and AU regions who rely on external calendar sync.

Root Cause

Microsoft introduced a stricter security rule on the calendar endpoint that began rejecting requests without a user-agent header. Our sync process, which programmatically consumed ICS feeds, did not include that header and consequently received HTTP 500 responses from the upstream service.

What We Did to Fix It

  • Added a standard browser User-Agent header to our ICS fetch requests and validated behaviour against affected tenants.
  • Deployed the change and confirmed normal sync behaviour through logs and targeted checks, then monitored until error rates returned to zero.

What We’re Doing Next

  • Provider compatibility checks – We’ve added automated checks to ensure our calendar sync remains compliant with provider requirements (e.g., required headers) before and after releases.
  • Faster detection & alerting – We’ve improved monitoring to spot calendar-sync anomalies sooner and alert our team for rapid action.
  • Greater resilience in the sync pipeline – We’ve refined retry/backoff behaviour and enhanced backfill routines so any missed events are recovered quickly once a provider error clears.
  • Safer release validation – Changes that could affect calendar sync will go through expanded staged testing against representative tenants.
  • Ongoing coordination with providers – We’re tracking provider guidance and upcoming changes to keep our integration current.

Closing Note

We’re sorry for the disruption this caused. Thank you for your patience while we worked with urgency to diagnose and resolve the issue. If you have any questions about how this impacted your site or want to review your calendar-sync configuration, please contact support@getequiem.com

Posted Aug 22, 2025 - 14:50 UTC

Resolved

Monitoring of the deployed fix has confirmed that it was successful and there are no further issues occurring.
Posted Aug 21, 2025 - 23:22 UTC

Monitoring

A fix has been implemented and Deployed to our production environments.
This should resolved the Calendar syncing with Office/Outlook calendars
We will continue to monitor the situation.
Posted Aug 21, 2025 - 14:32 UTC

Identified

The issue has been identified as Microsoft enforcing the security against the Calendar link
Posted Aug 21, 2025 - 13:45 UTC

Update

Our engineering team is continuing to investigate the issue. An update is expected by 9AM UTC on Friday 22nd of August 2025
Posted Aug 21, 2025 - 12:53 UTC

Investigating

We're aware of an issue affecting the bookings calendar sync functionality. Our engineering team is actively investigating the root cause and working on a resolution.
At this stage, the issue only impacts the third-party calendar sync feature. Bookings created and managed directly through the Equiem One platform are not affected.
Posted Aug 21, 2025 - 09:46 UTC
This incident affected: Mobile (Android, iOS), Web, and Supporting Applications (Equiem One).