Visitor Management degraded

Incident Report for Equiem

Postmortem

Summary

On 7 July 2026, between approximately 01:30 and 08:23 UTC, Visitor Management was unavailable in the Equiem web platform. Users attempting to open Visitor Management saw an error message instead of the appointments page. Visitor Management in Equiem One was unaffected throughout, so reception teams, workplace managers and building managers could continue to create and manage appointments there.

What happened

A software library update was deployed to the web platform at 00:55 UTC in preparation for an upcoming feature. The update was incompatible with the Visitor Management page, which began returning an error from approximately 01:28 UTC. The incompatibility was not caught by our pre-release testing.

The issue was reported to us at 07:33 UTC and an incident was declared. The root cause was identified at 07:44 UTC, a rollback was initiated at 07:52 UTC, and Visitor Management was fully restored at 08:23 UTC.

Impact

Visitor Management was unavailable via the web platform for around seven hours. Appointment management remained available in Equiem One for the full duration.

What we are doing about it

Two gaps let this reach production and stay there for several hours: our automated tests did not catch the incompatibility before release, and our monitoring did not detect the broken page before a customer did. Both are now addressed. We have added automated pre-deployment tests that block any release where Visitor Management or Bookings fails to render correctly, and we are extending synthetic monitoring across core modules so that failures of this kind are detected by us, immediately, rather than reported to us.

Posted Jul 23, 2026 - 21:19 UTC

Resolved

The issue has been monitored and we can confirm the service is up and running correctly.
Posted Jul 07, 2026 - 10:17 UTC

Monitoring

The underlying cause has been addressed and Visitor Management is now operational. We'll continue to monitor for stability.
Posted Jul 07, 2026 - 08:25 UTC

Identified

We have identified an issue affecting Visitor Management on the web platform. Equiem One and the mobile app are unaffected.
Our engineering team have identified the root cause and are working on a resolution.
Posted Jul 07, 2026 - 07:53 UTC
This incident affected: Web.