Intermittently Polls in Equiem are not not being displayed

Incident Report for Equiem

Postmortem

Summary of incident

  • Iris users were unable to embed polls in content.
  • They encountered error messages when editing existing content that contained embedded polls.
  • After editing and saving such content, the embedded polls were removed.
  • The polls already embedded in published content disappeared from those pages.

Root cause

We use Iframely to embed third-party content in our web app. This includes platforms like YouTube, Instagram, X (formerly Twitter), and others. Iframely supports the oEmbed format, which enables embedding rich content via URLs. Our polling system uses oEmbed through Iframely to embed polls in content.

Iframely maintains a whitelist of domains from which it allows content to be embedded. Several years ago, we requested and received approval to have our poll app’s domain added to this whitelist.

During this incident, we contacted Iframely support and learned that their team had recently conducted a routine review of whitelisted domains. As part of that review, they determined that our poll app’s domain was no longer valid and removed it from the whitelist. This removal caused embedded polls to break, leading to the issues users experienced.

After we submitted a support request, Iframely promptly restored our domain to the whitelist. However, due to internal caching on their end, we believe it took up to 24 hours for the fix to fully propagate and resolve the issue for existing polls.

Posted May 06, 2025 - 14:27 UTC

Resolved

We have identified the root cause of the polls display issue, which was related to a configuration error by a third-party provider we use to embed polls.

The provider has corrected the issue. Polls are now progressively restoring across the platform as systems and caches update. Full visibility of affected polls should return within the next 24 hours.

No further action is required from customers at this stage. We will continue monitoring until we are confident all polls have fully reloaded.

Thank you for your patience.
Posted Apr 25, 2025 - 14:35 UTC

Investigating

We’re currently aware of an issue affecting the display of Polls in content and are actively investigating the cause. In the meantime, we recommend moving the affected post to draft status to prevent users from encountering incomplete or missing content.
Posted Apr 25, 2025 - 12:11 UTC
This incident affected: Mobile (Android, iOS), Web, and Supporting Applications (Iris).