Multiple Web sites are returning an error

Incident Report for Equiem

Resolved

We have addressed the issue with some SSL Certificates being unable to be renewed and any affected sites are now restored to full operational ability.
Posted Sep 08, 2026 - 09:11 UTC

Investigating

We are currently experiencing issues with some sites returning an Privacy error.
We are working on rectifying as a matter of Priority
Posted Sep 08, 2026 - 08:37 UTC
This incident affected: Web.